среда, 21 сентября 2011 г.

Сборка пакетов для Midnight Commander

На днях закончил настройку сборочной среды для пакетов Midnight Commander. Сборка релизов еще окончательно не автоматизирована, а ночные срезы из git уже собираются автоматически (при условии, что в репозитарии есть изменения). Последний собранный релиз - 4.7.5.4 (его changelog)
Сейчас поддерживаются следующие цели для сборки:
  • Debian Lenny (i386, amd64)
  • Debian Squeeze (i386, amd64)
  • Debian Wheezy (i386, amd64)
  • Debian Sid (i386, amd64)
  • Ubuntu Lucid (i386, amd64)
  • Ubuntu Maverick (i386, amd64)
  • Ubuntu Natty (i386, amd64)
  • Ubuntu Oneiric (i386, amd64)

Настройки APT для релизов:
  • deb http://www.tataranovich.com/debian lenny main
  • deb http://www.tataranovich.com/debian squeeze main
  • deb http://www.tataranovich.com/debian wheezy main
  • deb http://www.tataranovich.com/debian sid main
  • deb http://www.tataranovich.com/debian lucid main
  • deb http://www.tataranovich.com/debian maverick main
  • deb http://www.tataranovich.com/debian natty main
  • deb http://www.tataranovich.com/debian oneiric main

Настройки APT для ночных срезов:
  • deb http://www.tataranovich.com/debian lenny nightly
  • deb http://www.tataranovich.com/debian squeeze nightly
  • deb http://www.tataranovich.com/debian wheezy nightly
  • deb http://www.tataranovich.com/debian sid nightly
  • deb http://www.tataranovich.com/debian lucid nightly
  • deb http://www.tataranovich.com/debian maverick nightly
  • deb http://www.tataranovich.com/debian natty nightly
  • deb http://www.tataranovich.com/debian oneiric nightly

Чтобы не произошла случайная замена пакета mc версией из nightly сборок, рекомендуется настроить APT pinning
Package: *
Pin: release c=nightly
Pin: origin www.tataranovich.com
Pin-Priority: -1

4 комментария:

  1. спасибо за пакеты!

    а можно делать билды для всех поддерживаемых Ubuntu + development?

    т.е. в данный момент 8.04, 10.04, 10.10, 11.04, 11.10 и 12.04.

    ОтветитьУдалить
  2. Попробовать можно. Скорее всего в более новых версиях проблем не будет.

    ОтветитьУдалить
  3. Ответы
    1. Поддержка самба отключена. Последний раз, когда я ее смотрел (samba в MC) - оно было нерабочее. С тех пор апстрим не анонсировал улучшений.

      Удалить