воскресенье, 3 июня 2012 г.

Установка OpenWrt на TP-LINK TL-WA901ND (hw rev 2.2)

Этот пост ориентирован на технически грамотную аудиторию. Если вы не обладаете необходимыми навыками - не пытайтесь повторить описанное. Я не несу никакой ответственности за ваши ошибки или возможный ущерб, возникший в следствии попытки повторить описанное.


Пару месяцев назад я приобрел точку доступа TP-LINK TL-WA901ND на замену своему старенькому роутеру D-Link DIR-320. Последний прослужил мне верой и правдой несколько лет, сначала работая на родной прошивке (было много глюков и каждый апдейт прошивки от производителя что-то чинил, а что-то ломал), потом была DD-WRT, а закончил роутер свой путь с OpenWRT на борту.

Последняя прошивка доставила массу положительных эмоций. Работа роутера стала надежной и предсказуемой, а настройки по-умолчанию устроили меня почти полностью (пришлось немного допилить, чтобы перенести свои наработки с dd-wrt, но это мелочи).

Первое знакомство с прошивкой от TP-Link порадовало своей простотой и продуманностью настроек. После подключения я сделал пару замеров скорости - выходили стабильные 80-110Mb/s при работе как со стационарного компа, так и нетбука.

А вот вчерашний вечер стал темным пятном на репутации tp-link'а - внезапно начал заикаться XBMC при проигрывании фильмов с домашнего сервера к которому он подключен через WI-FI. Тогда было лень разбираться в причинах и я просто пошел спать оставив проблему на следующий день.

Сегодня сев за комп, я вспомнил про вчерашние проблемы у проигрывателя и решил посмотреть в чем причина его "заиканий". Попытка скопировать фильм на комп показала скорость около 600-800kb/s - блин! и это на оборудовании стандарта N. Первым делом перезагрузил точку доступа - не помогло. Потом при помощи смартфона просканил диапазон - мало-ли кто-то еще сел на мой канал и мешает работе точки - такого злодея не нашлось.

Я еще около часа копался в настройках прошивки меняя каналы, стандарты и прочие настройки, которые могли иметь отношение к скорости. Все бесполезно. Последним рывком стала установка последней версии прошивки и сброс настроек - но и это не дало желаемого прироста в скорости.

Пока я искал прошивку - наткнулся на упоминание, что модель TL-WA901ND поддерживается в DD-WRT (правда только ревизия v1.x). Дальнейшее изучение форумов дало наводку на OpenWRT, где уже имеется поддержка моей ревизии.

ВАЖНО! Для завершения установки новой прошивки вам необходимо обеспечить доступ устройства в интернет через LAN порт. Если вы не знаете как это сделать не пытайтесь обновить прошивку устройства!

Важно правильно определить аппаратную ревизию вашего устройства: V1.x или V2.x. Если вы не знаете как это сделать смотрите тут. Для прошивки через web-админку TP-Link нужна прошивка с суффиксом -factory, прошивки с суффиксом -sysupgrade подходят ТОЛЬКО для обновления уже установленной OpenWRT.

Следуя инструкции, скачал  прошивку, собранную из trunk. Залил ее через "Firmware upgrade" в web-интерфейсе прошивки TP-Link. После завершения роутер перезагрузился и в сети появился адрес 192.168.1.1.

Дальше нужно зайти через telnet на устройство и провести первоначальную настройку. У меня Linux, но для Windows вам подойдет putty. Настройте параметры "Host Name (or IP address)", "Port" и "Connection type" как показано на скриншоте и жмите кнопку "Open".


Затем задал пароль root и после этого смог зайти по SSH. После настроил резолвер, дефолтный гейтвей и поставил luci.

# passwd root
# echo 'nameserver 8.8.8.8' > /etc/resolv.conf
# route add default gw ip-адрес-вашего-шлюза-в-интернет
# opkg update
# opkg install luci
# /etc/init.d/uhttpd enable
# /etc/init.d/uhttpd start

После этого можно было зайти в web интерфейс Luci (http://192.168.1.1/) и настроить точку доступа окончательно. После всех настроек скорость копирования через NFS/SCP/SMB поднялась до 7-9MB/s что вполне хорошо и соответствует моим ожиданиям.


Этот пост ориентирован на технически грамотную аудиторию. Если вы не обладаете необходимыми навыками - не пытайтесь повторить описанное. Я не несу никакой ответственности за ваши ошибки или возможный ущерб, возникший в следствии попытки повторить описанное.

173 комментария:

  1. Привет, помоги, пожалуйста.
    Залил прошивку, подцепился через putty, поменял пароль, но дальше ничего не происходит, ввожу команды

    # opkg update
    # opkg install luci

    приходит ответ что не может скачаться пакет, как его скачать? и подпихнуть?

    Заранее благодарен за ответ.

    ОтветитьУдалить
    Ответы
    1. А сеть настроена (ip + gateway)?

      Удалить
    2. т.е.? у меня есть еще одна точка, я не могу к ней подцепиться, или же надо как-то иначе?

      Удалить
    3. Точка в режиме AP или Client?

      Удалить
  2. Тогда на ее ethernet интерфейсе должен быть настроен ip адрес, шлюз по-умолчанию и DNS сервер. Только после этого можно будет ставить пакеты.

    Какой адрес сети и дефолтного шлюза?

    ОтветитьУдалить
  3. шлюз 192.168.1.2
    а сеть ты имеешь ввиду местную?

    ОтветитьУдалить
    Ответы
    1. route add default gw 192.168.1.2
      echo 'nameserver 8.8.8.8' > /etc/resolv.conf
      opkg update
      opkg install luci

      Сбрось вывод всех команд на pastebin.com

      Удалить
    2. сделал все как ты сказал, точка немного задумывается, а затем выдает вот это


      root@OpenWrt:~# opkg update
      Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
      wget: bad address 'downloads.openwrt.org'
      Collected errors:
      * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1.

      Удалить
    3. если с компа то все работает, или надо с точки пингануть?

      Удалить
    4. С точки. Все, что я пишу, нужно на точке делать.

      Удалить
    5. понял, с точки пинг не идет...

      Удалить
    6. Куда подключен ethernet порт точки доступа?

      Удалить
    7. сейчас к компу, попробовать в качестве DNS прописать ip компа?

      Удалить
  4. Ответы
    1. вобщем чего-то я туплю, ничего не получается.

      Удалить
  5. Андрей, всё понятно, получилось и оказалось довольно просто. Связь появилась (DHCP, что бы ей не появиться?), но есть одна проблема.

    Не подключается по SSH через WiFi, ругается "ssh: connect to host 192.168.1.1 port 22: Connection refused".

    При этом! Один раз случайно подключилось, отдало-спросило ключ, но я не указал логин и вышел по CTRL+C. Больше такого чуда не происходило.

    Через кабель всё ок. Но так как дырка для кабеля одна, получается, что или SSH, или интернет - веб-интерфейс натянуть таким образом не понимаю как.

    Может, что-то в конфиге нужно поправить, чтобы консоль по SSH через WiFi не блокировалась? Такое вообще есть?

    Роутер такой же, как у вас.

    ОтветитьУдалить
    Ответы
    1. Приведу пример для своей версии OpenWRT (r32012). Зайти в web-админку и выставить настройку System/Administration/SSH Access/Dropbear Instance/Interface = Unspecified.

      Удалить
  6. Спасибо вам... у меня подгорелый tp-link 841
    инет смог подать отредактировав через WinSCP настройки сети
    но не получалось установить luci
    после резолва -- все получилось!
    еще раз СПАСИБО )))

    ОтветитьУдалить
  7. Привет.
    Сделал все как ты написал в блоге, установил прошивку, зашел через Telnet, поставил luci, зашел в web интерфейс и настроить точку доступа. Ну почти настроил... Забыл сменить IP адрес. Когда вспомнил об этом и попытался опять зайти на web интерфейс увидел черный экран и на секунд 3-5 сообщение:"LuCI-Lua Configuration Interface" и дальше "Веб-страница недоступна".
    Если знаешь то подскажи, пожалуйста, что делать?

    ОтветитьУдалить
    Ответы
    1. Либо перепрошить заново, либо подключить кабелем к компу и настроить дефолтный адрес. У OpenWRT есть еще failsafe режим, но мне не доводилось им пользоваться.

      Удалить
  8. А как в таком случае можно его перепрошить? По веб-интерфэйсу зайти не могу, по telnet так же...

    ОтветитьУдалить
    Ответы
    1. http://wiki.openwrt.org/toh/tp-link/tl-wa901nd

      Пробовали зайти в failsafe режим, как описано в wiki? Если не помогло, то скорее всего придется подключаться через serial и заливать прошивку через него.

      Удалить
  9. меняем ip

    telnet 192.168.1.1

    root@openwrt:~$ passwd
    Changing password for root
    New password:
    Retype password:
    Password for root changed by root
    root@openwrt:~$

    ОтветитьУдалить
  10. telnet 192.168.1.1

    vi /etc/config/network

    config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.133'
    option netmask '255.255.255.0'
    option gateway '192.168.0.1'
    option dns '192.168.0.1'


    ОтветитьУдалить
  11. не завелось
    вернулся назад

    root@OpenWrt:~# /etc/init.d/network reload
    /sbin/wifi: eval: line 1: hostapd_set_log_options: not found
    /sbin/wifi: eval: line 1: hostapd_set_bss_options: not found
    /sbin/wifi: eval: line 1: hostapd: not found
    Failed to start hostapd for phy0


    hostapd - не поставилось

    ОтветитьУдалить
  12. wpad-mini и hostapd-mini отсутствуют в списке пакетов транка (архитектура ar71xx)
    Без них Wi-Fi не работает.
    Возможно нет поддержки Wi-Fi чипсета, но без него ценность прошивки стремится к нулю.

    ОтветитьУдалить
    Ответы
    1. Уважаемый, вы вообще о чем? Какого чипсета? Какой прошивки? Тут обсуждают TP-Link TL-WA901ND (hw rev 2.2) + OpenWRT и все работает включая Wi-Fi.

      Удалить
  13. Я про 901 и пишу. Образ openwrt-ar71xx-generic-tl-wa901nd-v2-squashfs-factory.bin на точку встал, но при попытке запустить Wi-Fi он пишет, то же что и у человека выше - Failed to start hostapd. В инструкциях по настройке, рекомендуют поставить hostapd или wpad, но в списке пакетов для ar71xx их нет (если обратите внимание, то это архитектура прошивки с OpenWrt).

    Чипсет Wi-Fi Atheros AR5416.

    Попробую на форуме спросить.

    ОтветитьУдалить
    Ответы
    1. Возможно за пол-года что-то сломали в trunk и сейчас оно действительно может не работать. Попробую поискать образ, с которого я шил свою точку.

      А Wi-Fi конфигурировался через /etc/config/network или через luci?

      Удалить
    2. Пакеты появились, собраны сегодня.

      Удалить
    3. Через /etc/config/wireless Проблема, скорее всего, связана с персборкой пакетов, перед которой их снесли.

      Удалить
    4. Расскажите потом получилось ли завести wi-fi. Сам пока не планирую обновлять прошивку, но интересна перспектива.

      Удалить
    5. Wi-Fi поднялся после установки wpad-mini. С включенным 40MHz каналом, соединяется на 300Mbit, но реальную скорость не мерял.
      Потоковое видео на HTPC передается без проблем.

      Удалить
  14. Подскажите пожалуйста как ВЫ устанавливали Luci если точка подключена только к компу.....

    ОтветитьУдалить
    Ответы
    1. Подключил к серверу, который интернет раздает. К компу точка была подключена только на время прошивки.

      Удалить
    2. Я его подключил к роутеру который у меня инет раздает по DHCP, IP у роутера и этой точки доступа поставил разные, зашел с компа которому этот роутер тоже инет раздает, подключился к точке через PuTTY ввел пароль все законектилось НО в ответ на opkg update получил что он не может связаться с сервером.... Так как всетаки поставить ВЕБ-интерфейс

      Удалить
    3. Добавить ip адрес недостаточно. Нужно еще указать шлюз по-умолчанию.

      Присмотритесь в статье к строке route add default.

      Удалить
  15. настроил (это я первый аноним у которого не завелось :))

    ОтветитьУдалить
    Ответы
    1. заметил что торренты на телефоне стали лучше качаться, видимо дефолтная прошивка не очень

      Удалить
    2. Как настроил? У меня все устанавливается и работает, кроме вафли - в /etc/config/wireless - пусто (hw 2.0).

      Удалить
    3. Я wi-fi настраивал уже через web-интерфейс Luci.

      Похоже с той поры, как я ставил openwrt на свою точку что-то в прошивке поменяли. Мне не первый раз пишут, что повторяя мои действия у людей не работает в итоге.

      Удалить
    4. поменяли не в прошивке, поменяли (95% вероятности) в железе. Жалко пока на гарантии - так бы сравнил с другом. Что характерно у друга точка выпущена на полгода раньше, но 2.2, а у меня 2.0. В люське вафли нет вообще - только лан. Гаргулья работает, но нормального режима AP+DHCP клиент я в ней не нашел.

      Удалить
    5. Так если бы железо поменялось, то должны hw revision поменять, хотя... tp-link, китайцы =)

      Удалить
    6. я первый аноним
      настроил через веб
      просто в первый раз там вообще не было пакетов, потом их пнули и пакеты походу появились

      Удалить
    7. у меня r35509

      Удалить
  16. Анонимный9 марта 2013 г., 7:24

    OpenWrt Barrier Breaker r35896 / LuCI Trunk (trunk+svn9677) Kernel 3.8.2, вафля появилась и заработала, но коннектится в режиме только 54 мегабита, даже с устройствами стандарта n.

    ОтветитьУдалить
  17. Хотелось бы задать еще один глупый вопрос. В чем отличие прошивок и есть ли оно вообще?
    1)openwrt-ar71xx-generic-tl-wa901nd-v2-jffs2-factory.bin
    2)openwrt-ar71xx-generic-tl-wa901nd-v2-jffs2-sysupgrade.bin
    3)openwrt-ar71xx-generic-tl-wa901nd-v2-squashfs-factory.bin
    4)openwrt-ar71xx-generic-tl-wa901nd-v2-squashfs-sysupgrade.bin
    Удалось нагуглить только отличие jffs2 от squashfs >> http://wiki.openwrt.org/doc/techref/filesystems#squashfs
    А вот разницу между factory и sysupgrade вообще не догнал. А шить стремно, вдруг девайс кирпичну.

    ОтветитьУдалить
    Ответы
    1. Ну разницу между squashfs и jffs вы уже сами раскопали, а разница между *factory.bin - для заливки OpenWRT через админку родной прошивки TP-Link, а *sysupgrade.bin - апгрейд уже установленной OpenWRT.

      Если у вас родная прошивка, то нужен вариант с *factory.bin. В Wiki есть подробное руководство - http://wiki.openwrt.org/toh/tp-link/tl-wa901nd#installation1

      Удалить
  18. Андрей, подскажите пожалуйста как сменить IP адрес точки по SSH.
    По телнету уже не ходит в точку.

    ОтветитьУдалить
    Ответы
    1. А после чего оно перестало по telnet заходить?

      Удалить
  19. После того как пароль выбрал по телнет, и больше не заходит.
    С точкой и до перепрошивки творились чудеса, с первого раза не включалась, т.е. включалась, пинговалась, но не подымала WIFI модуль, по веб интерфейсу не ходило.
    С 3-5 раза включалась и до следующей перезагрузки работала без проблем, шил разными заводскими прошивками.

    ОтветитьУдалить
    Ответы
    1. Сменить ip можно зайдя через SSH и отредактировав файл /etc/config/network

      У меня он выглядит так:

      config interface 'loopback'
      option ifname 'lo'
      option proto 'static'
      option ipaddr '127.0.0.1'
      option netmask '255.0.0.0'

      config interface 'lan'
      option ifname 'eth0'
      option type 'bridge'
      option proto 'static'
      option netmask '255.255.255.0'
      option ipaddr '192.168.0.xxx'
      option gateway 'gw-ip-address'
      option broadcast '192.168.0.255'
      option dns '8.8.8.8'

      После редактирования, нужно перезагрузить сеть

      /etc/init.d/network restart

      Удалить
    2. Не знаю, мож что-то неправильно?
      ввожу:
      root@OpenWrt:~# /etc/config/network
      Жму Enter, получаю:
      -ash: /etc/config/network: Permission denied
      root@OpenWrt:~#

      Доступ запрещен. Почему ?

      Удалить
    3. Это текстовый файл, а не программа. Его нужно отредактировать в текстовом редакторе. В OpenWRT есть редактор vi

      # vi /etc/config/network

      Этот редактор не похож на notepad =) Краткая справка тут: http://www.washington.edu/computing/unix/vi.html

      Если очень кратко, то после запуска нужно нажать Insert (слева снизу появится зкак 'I'), затем отредактировать текст. Для сохранения файла нужно нажать Esc, затем :wq

      Удалить
    4. Спасибо БОЛЬШОЕ, прояснили :)
      Все получилось, в инет я его пустил, luci установил, буду разбираться с web интерфейсом.

      Удалить
    5. Здравствуйте, Андрей.
      Сбросил точку в заводские, через web. Сбросилась полностью, сеть настроил /etc/config/network, а вот luci не устанавливается, не пойму почему.

      root@OpenWrt:~# ping ya.ru
      PING ya.ru (213.180.193.3): 56 data bytes
      64 bytes from 213.180.193.3: seq=0 ttl=58 time=50.324 ms
      64 bytes from 213.180.193.3: seq=1 ttl=58 time=47.747 ms

      ^C

      root@OpenWrt:~# opkg update
      Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
      Updated list of available packages in /var/opkg-lists/barrier_breaker.
      root@OpenWrt:~# opkg install luci
      Unknown package 'luci'.
      Collected errors:
      * opkg_install_cmd: Cannot install package luci.

      Удалить
    6. Скорее всего luci еще не собрали в текущем транке. Попробуйте позже.

      Удалить
  20. ребята день добрый! я залил прошивку в роутер, поменял на нем пароль. Дальше вообще не вьезжаю. Можно ли как нибудь откатить эту прошивку?

    ОтветитьУдалить
    Ответы
    1. Стоит начать отсюда: http://wiki.openwrt.org/doc/howto/generic.uninstall

      Удалить
    2. ничего не дало, есть ли какой нибудь мануал? или способ залить в него прошивку по fttp

      Удалить
    3. Немного конкретики не помешает - что конкретно делали и какой результат?

      Удалить
  21. или выкинуть этот роутер в мусорку?

    ОтветитьУдалить
  22. Сделал до пункта со сменой пароля
    после команды root@OpenWrt:~# opkg update
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
    wget: bad address 'downloads.openwrt.org'
    Collected errors:
    * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz, wget returned 1
    я наверное чего-то не понимаю, как что-то может качаться по ссылке если ноут подключен к роутеру по кабелю и нет доступа в интернет??

    ОтветитьУдалить
    Ответы
    1. Ну во первых сабж не роутер, а точка доступа. А во вторых в чем проблема раздать ему интернет через ноутбук? 3G модем или подключить телефон кабелем...

      Удалить
    2. Я думал об этих вариантах...но в данный момент ни один из них мне не доступен...есть возможность подключить точку доступа к коммутатору и ноут к коммутатору(D-Link des-1005A) провайдер билайн.?

      Удалить
    3. не особо получается...либо интернет работает, либо я могу зайти в интерфейс ТД

      Удалить
    4. А подключив ноутбук к коммутатору нужно еще запускать соединение (PPPoE или PPTP) на ноутбуке или ноутбук получает нужные параметры от провайдера по DHCP?

      Удалить
    5. во общем подключил Билан-модем(3G) все равно ни чего не скачивает

      Удалить
    6. # vi /etc/config/network
      config interface 'loopback'
      option ifname 'lo'
      option proto 'static'
      option ipaddr '127.0.0.1'
      option netmask '255.0.0.0'

      config interface 'lan'
      option ifname 'eth0'
      option type 'bridge'
      option proto 'static'
      option netmask '255.255.255.255'
      option ipaddr '192.168.1.x'
      option gateway 'gw-ip-address'
      option broadcast '10.231.14.221'
      option dns '217.118.66.243'

      так отредактировал файл,теперь не могу зайти в ТД...что делать((?

      Удалить
    7. во общем подключил Билан-модем(3G) все равно ни чего не скачивает
      Подключить модем недостаточно - нужно настроить 3g соединение таким образом, чтобы им могли пользоваться другие (не помню как это в windows называется), затем настроить tp-link для использования ip адреса ноутбука с 3g модемом в качестве шлюза по-умолчанию.

      Делается примерно так:

      route del default
      route add default gw x.x.x.x dev br-lan

      x.x.x.x - ip адрес ноутбука.

      Относительно редактирования /etc/config/network и пропадания доступа после этого - вы задали адрес 192.168.1.x/255.255.255.255, а броадкаст - 10.231.14.221 - скорее всего что-то неверно.

      Если ошибочно задали адрес, то выставьте на ноутбуке адрес из того же диапазона и смените настройки.

      Удалить
    8. Спасибо что нашли для меня время...по поводу редактирования сбросил через безопасный режим

      Удалить
  23. Есть простая прошивка на русском языке чтобы просто изменить Mac адрес?
    для TL-WA901ND

    ОтветитьУдалить
    Ответы
    1. Трудно сказать, для меня и openwrt простая прошивка (в ней можно сменить MAC) и русский туда можно поставить (пакет luci-i18n-russian).

      А разве сменить MAC нельзя в оригинальной прошивке TP-Link?

      Удалить
    2. Оно и заметно,даже по-русски объяснить невозможно, как сделать что-бы пакеты качались...

      Удалить
    3. на родной прошивке нельзя менять

      Удалить
    4. Если у вас первая ревизия (hw rev. 1.0), то возможно подойдет прошивка от dd-wrt. Там будет веб-интерфейс из коробки. Насчет русского - не знаю.

      Только есть одно но, выше по треду люди жалуются, что даже залив прошивку, которую шил я у них не получается завести wi-fi или он заводится, но на низкой скорости. Возможно tp-link не гнушается менять железо и не менять hw revision.

      Удалить
    5. Оно и заметно,даже по-русски объяснить невозможно, как сделать что-бы пакеты качались...

      У вас незнание и непонимаение предметной области, вам не важно на каком языке объяснять - результат будет одинаковый. Найдите в своем городе спеца, который согласится сделать нужное вам и не дурите мне голову. У меня нет ни времени, ни желания разжевывать вам элементарные вещи.

      Удалить
  24. Здравствуйте, Андрей. Установил через время luci.
    А может подскажите, мне бы хотелось настроить точку с wan портом. Т.е. есть две локалки, это точка работает в режиме AP и воткнута в свич с сеткой 192.168.1.x и шлюзом 192.168.1.1, вторая точка подключается клиентом к этой и получает ip 10.0.0.x и становиться шлюзом 10.0.0.100 и тоже воткнута в простой свич. Я так понимаю нужно сделать в точке разные VAN, и как-то прописать маршруты, если это не очень сложно подскажите, и дайте ссылочку где такое настраивают. Спасибо!

    ОтветитьУдалить
    Ответы
    1. Ваше описание похоже на этот случай. Только не понятно где у вас выход в интернет и есть ли он вообще.

      Удалить
  25. Да интернет есть, 192.168.1.1 - это роутер.
    Спасибо буду разбираться

    ОтветитьУдалить
  26. Перевёл роутер в режим "failsafe" (Подключите кабель блока питания, как только начнет мигать лампочка SYS - нажмите на кнопку RESET.
    При этом лампочка SYS начнет мигать очень часто)
    Хочу сбросить в заводские установки, ввожу команды:
    root@(none):/# mount_root
    Unlocking rootfs ...
    root@(none):/# firstboot
    firstboot has already been run
    jffs2 partition is mounted, only resetting files
    MTD partition not found.

    ОтветитьУдалить
    Ответы
    1. Прошивка openwrt-ar71xx-generic-tl-wa901nd-v2-jffs2-factory.bin

      Удалить
    2. При смене пароля командой "passwd" выдаёт ошибку:
      passwd: can't create '/etc/shadow+': No space left on device
      passwd: can't update password file /etc/shadow

      Что делать?

      Удалить
    3. Покажите вывод mount

      По-идее сменить пароль можно после загрузки в fail safe и выполнении команды mount_root

      Тут смотрели?

      Удалить
    4. root@(none):/# mount
      rootfs on / type rootfs (rw)
      /dev/root on / type jffs2 (rw,noatime)
      proc on /proc type proc (rw,noatime)
      sysfs on /sys type sysfs (rw,noatime)
      tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14612k)
      tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
      devpts on /dev/pts type devpts (rw,noatime,mode=600)
      root@(none):/#

      Удалить
    5. Ну я так и делал:

      root@(none):/# mount_root
      Unlocking rootfs ...
      root@(none):/# firstboot
      firstboot has already been run
      jffs2 partition is mounted, only resetting files
      MTD partition not found.

      Удалить
    6. А что покажет ls -1 /dev/mtdblock* ?

      Пробовали сменить пароль сразу после mount_root без запуска firstboot? Что скажет на команду

      mkdir /overlay-tmp
      mount -t jffs2 /dev/mtdblock3 /overlay-tmp

      Удалить
    7. Через телнет не заходит когда просто включена точка.

      Вот что выдают ваши команды:

      root@(none):/# ls -1 /dev/mtdblock*
      /dev/mtdblock0
      /dev/mtdblock1
      /dev/mtdblock2
      /dev/mtdblock3
      /dev/mtdblock4
      root@(none):/# mkdir /overlay-tmp
      mkdir: can't create directory '/overlay-tmp': Read-only file system
      root@(none):/# mount -t jffs2 /dev/mtdblock3 /overlay-tmp
      mount: mounting /dev/mtdblock3 on /overlay-tmp failed: No such file or directory

      Удалить
    8. Этот комментарий был удален администратором блога.

      Удалить
    9. Пробовал сменить - точно такую же ошибку выдаёт.

      passwd: can't create '/etc/shadow+': No space left on device
      passwd: can't update password file /etc/shadow


      а вот с mount_root ваши команды:

      root@(none):/# mount_root
      Unlocking rootfs ...
      root@(none):/# ls -1 /dev/mtdblock*
      /dev/mtdblock0
      /dev/mtdblock1
      /dev/mtdblock2
      /dev/mtdblock3
      /dev/mtdblock4
      root@(none):/# mkdir /overlay-tmp
      mkdir: can't create directory '/overlay-tmp': No space left on device
      root@(none):/# mount -t jffs2 /dev/mtdblock3 /overlay-tmp
      mount: mounting /dev/mtdblock3 on /overlay-tmp failed: No such file or directory

      Удалить
    10. У меня на один больше "разделов" в mtd

      ls -1 /dev/mtdblock*
      /dev/mtdblock0
      /dev/mtdblock1
      /dev/mtdblock2
      /dev/mtdblock3
      /dev/mtdblock4
      /dev/mtdblock5

      Возможно по этой причине и не срабатывает firstboot. Попробуйте заново прошить прошивку и повторить все с начала.

      Удалить
    11. Здравствуйте! Такая же ситуация как и у Андрей Хромых. Вы посоветовали заново прошить прошивку. Но как это сделать если к роутеру есть доступ только через fail safe?

      Удалить
    12. За успех не поручусь, но можно попробовать так: http://blog.tataranovich.com/2013/05/tp-link-tl-wa901nd-debrick.html

      Удалить
    13. Здравствуйте! Все точно так как и у Андрей Хромых. Пробовал так: http://blog.tataranovich.com/2013/05/tp-link-tl-wa901nd-debrick.html.
      В результате не начал пинговаться ya.ru
      ping ya.ru
      ping: bad address 'ya.ru'
      Прошу помощи?

      Удалить
    14. Какой адрес вы прописали в команде "route add default gw ..." ?

      Удалить
    15. 192.168.1.15 - это адрес моего устройства, которое раздавало интернет в тот момент. У вас скорее всего другой адрес будет (если вообще будет).

      Удалить
    16. Ввел свой адрес (192.168.1.33) - ситуация не изменилась. А в этой строчке: echo 'nameserver 8.8.8.8' > /etc/resolv.conf, все так и должно быть?

      Удалить
  27. Доброе время суток!
    Прошу помощи прошил всё нормально не могу поставить веб интерфейс LUCI. как его поставить без интернета. интернет раздается по dhcp конфигурацию не знаю как настроить вручную , раздача идёт с адреса 192.168.1.1 dns и шлюз тотже.
    За ранее очень благодарен!

    ОтветитьУдалить
    Ответы
    1. Sergey, настройка сети описана в wiki проекта openwrt.

      Несколько упоминаний по настройке сети есть в этом треде - прочтите его с самого начала.

      Удалить
  28. Ночи доброй у меня вопрос! После этой прошивки незаходит на модем по ip 192.168.1.1

    ОтветитьУдалить
    Ответы
    1. А 192.168.1.1 пингуется? Если нет, то как вы прошивали?

      Удалить
  29. Анонимный1 мая 2013 г., 18:33

    короче после статьи прошил и убир роутер

    ОтветитьУдалить
    Ответы
    1. А какая hardware revision у "покойного" роутера?

      Удалить
    2. Анонимный1 мая 2013 г., 19:58

      Прошил через упдейтер на: openwrt-ar71xx-generic-tl-wa901nd-v1-squashfs-sysupgrade роутер бил 3.11.2 Build 100429 Rel.75965n. Что теперь мне сделать? помогите пожалуста

      Удалить
    3. Анонимный1 мая 2013 г., 20:07

      Издевательства над роутером продолжаю:
      1. Выключить роутер из эл. сети.
      2. Компютер подключен к роутеру через LAN1
      3. Прописать в настройках сетевой карты статический IP в диапазоне 192.168.1.2
      4. Включаем роутер в сеть и ждем пока начнет мигать лампочка sys
      5. Как только начнет мигать лампочка sys несколько раз нажать кнопку reset на задней панели
      6. Если все сделано правильно то лампочка sys будет мигать интенсивнее
      7. Запускаем Putty и заходим через telnet по адресу 192.168.1.1

      а дальше что делать?
      или етот роутер можно вибросить уже?
      если кто может помоч добавтесь пожалуста в скайп Eundgel32

      Удалить
    4. Для начала нужно ответить на мой вопрос - какая аппаратная ревизия у вашей точки доступа?

      Если не знаете как это сделать, то смотрите тут. Или сфотографируйте наклейку на его дне и выложите снимок в инет.

      Удалить
    5. Анонимный1 мая 2013 г., 20:13

      TL-WA901ND V1

      Удалить
    6. А шили через Wi-Fi или Ethernet?

      Удалить
    7. Анонимный1 мая 2013 г., 20:34

      Ethernet - была включена в свитч через обновления прошивки

      Удалить
    8. Авторизуйте меня в скайпе: andrey.tataranovich

      Удалить
  30. Анонимный2 мая 2013 г., 8:31

    А ет правда Transmit Power 27dBm (500mW)

    ОтветитьУдалить
    Ответы
    1. Тот факт, что 27dBm = 500mW - правда, но вот может ли раскачать столько девайс - наврятли.

      http://www.tp-link.com/lk/products/details/?model=TL-WA901ND#spec

      EIRP <20dBm(EIRP)

      Удалить
    2. Анонимный4 мая 2013 г., 14:44

      После установки OpenWrt установил канаду (там нет ограничения EIRP <20dBm) то показало 27dBm передача после того как удалил профиль и создал наново сеть ставлю канаду 27dBm а реальних показивает 22dBm. Наверное какойто глюк был когда показивало реальних 27dBm

      Удалить
  31. Анонимный3 мая 2013 г., 14:17

    Спасибо, за Ваш блог. Информация на вес золота. Смирнов Станислав

    ОтветитьУдалить
  32. Анонимный4 мая 2013 г., 14:51

    Большое спасибо автору за помощь он меня спас после того как я практически убил роутер не той прошивкой он мне его ожывил. Andrey Tataranovich ради того чтоб ожывить мне роутер потратил свой час на переписку в скайпе на установку OpenWrt через Tim Wiewer. Спасибо.
    Роман Гончар

    ОтветитьУдалить
  33. Здравствуйте, помогите мне пожалуйста с настройкой точки, подключитесь ко мне через TeamViewer. Не бесплатно)))

    ОтветитьУдалить
  34. Анонимный16 июня 2013 г., 16:55

    Здравствуйте! Прошился на dd wrt v2.2, поставил luci, хочу добавить QoS - не хватает места. Показывает 72 кб свободно из 1 метра примерно. Установка стандартная - чем могло забиться место? Или у всех так мало места остается? Кто ставил себе QoS?
    И еще такая проблема: поставил русский язык, потом удалил чтоб освободить место. Решил поставить заново - No space left on device. Может где-то есть почистить кеш по WinSCP?

    ОтветитьУдалить
    Ответы
    1. Насчет DD-WRT не знаю, но на openwrt у меня для записи свободно 528.0K из 1.4M. Ради эксперимента я попробовал установить и удалить tcpdump - после удаления место корректно освободилось.

      Удалить
    2. Этот комментарий был удален автором.

      Удалить
    3. А если корректно не освободилось, есть какая-нить команда (для очистки кэша например)?

      Удалить
    4. А как вы удаляли пакет? Он точно удалился и не выводится командой "opkg list-installed"?

      Удалить
  35. Приветствую!
    Предыстория: TL-WA901ND Ver 2.3, на родной (wa901nv2_en_3_12_16_up(130131)) прошивке пропадает wifi, сеть видна - данные не идут. Прошился на OpenWRT - только с постоянные удержанием кнопки reset стартует, установил там web-интерфейс, вроде запустилась. Но с запуском через reset - это не работа. Поэтому стабильность даже не тестировал. Залил DD-WRT, хочу настроить в режиме AP, но LAN порт мертвый. Инструкцию выполнял http://www.dd-wrt.com/wiki/index.php/Repeater_Bridge.
    Может есть ещё какие соображения по этому поводу?

    ОтветитьУдалить
    Ответы
    1. А как вы определили, что LAN порт "мертвый"?

      Удалить
  36. Анонимный30 июня 2013 г., 1:05

    Здравствуйте!
    Помогите, пожалуйста! После неудачной прошивки роутер (v 2.3) был переведен в fail safe
    вот что я после этого сделал

    root@(none):/# mount_root
    mount_root: jffs2 is ready
    root@(none):/# passwd
    Changing password for root
    New password:
    Bad password: too weak
    Retype password:
    Password for root changed by root
    root@(none):/# uci get network.lan.ipaddr
    uci: Entry not found
    root@(none):/# firstboot
    jffs2reset: This will erase all settings and remove any installed packages. Are you sure? [N/y]
    y
    jffs2reset: /dev/mtdblock3 is mounted as /overlay, only ereasing files
    root@(none):/# mtd -r erase rootfs_data
    Unlocking rootfs_data ...
    Erasing rootfs_data ...
    Rebooting ... на этом он завис, помогло выкл/вкл но после этого он опять оказался в режиме fail safe (оч. часто мигает лампочка sys.)
    Как его вернуть в обратный режим? Что я не так сделал?

    ОтветитьУдалить
    Ответы
    1. Анонимный1 июля 2013 г., 20:54

      Проделал все по инструкции по восстановлению
      http://blog.tataranovich.com/2013/05/tp-link-tl-wa901nd-debrick.html
      Помогло.
      Спасибо!

      Удалить
    2. Рад слышать, что инструкция оказалась полезной. Потребовались ли какие-то другие действия, не описанные в инструкции?

      Удалить
  37. Спасибо)) Разобрался, поставил русский язык, буду тестировать, потом отпишусь

    ОтветитьУдалить
  38. промучился с установкой.
    все идет до момента установки LUCI
    она не ставится из за недостатка памяти...

    не настолько продвинут, чтоб конфигурить командрой строкой.

    может кто знает, есть ли облегченная LUCI?

    ОтветитьУдалить
    Ответы
    1. А какой памяти не хватает - оперативной или на встроенной флешке?

      Насчет облегченной LUCI не подскажу, я не спец по openwrt - настроил, задокументировал и забыл.

      Скоро собираюсь брать еще одну точку доступа (скорее всего TP-Link TL-WA701ND) и буду ее прошивать на свежий OpenWRT - вот тогда и обновлю инфу.

      Удалить
    2. Не хватает встроенной памяти (rootfs)
      Причем не вмещается даже облегченная установка luci (Minimalistic offline installation)
      http://wiki.openwrt.org/doc/howto/luci.essentials
      на моменте установки luci-mod-admin-full вываливается сообщения о недостатке памяти и куча ошибок.
      uhttpd стартануть можно, однако веб интерфейс валится с ошибкой.

      Впечатление такое, что развитие проекта luci ушло далеко за рамки объема памяти нашего девайса.
      Нашел множество отзывов о такой проблеме.
      Решение пока нет...

      Удалить
    3. Мне повезло:

      root@OpenWrt:~# opkg list-installed \*luci\*
      luci - trunk+svn8687-1
      luci-app-firewall - trunk+svn8687-1
      luci-i18n-english - trunk+svn8687-1
      luci-lib-core - trunk+svn8687-1
      luci-lib-ipkg - trunk+svn8687-1
      luci-lib-lmo - trunk+svn8687-1
      luci-lib-nixio - trunk+svn8687-1
      luci-lib-sys - trunk+svn8687-1
      luci-lib-web - trunk+svn8687-1
      luci-mod-admin-core - trunk+svn8687-1
      luci-mod-admin-full - trunk+svn8687-1
      luci-proto-core - trunk+svn8687-1
      luci-proto-ppp - trunk+svn8687-1
      luci-sgi-cgi - trunk+svn8687-1
      luci-theme-base - trunk+svn8687-1
      luci-theme-openwrt - trunk+svn8687-1

      root@OpenWrt:~# df -h
      Filesystem Size Used Available Use% Mounted on
      rootfs 1.4M 864.0K 544.0K 61% /
      /dev/root 1.5M 1.5M 0 100% /rom
      tmpfs 14.3M 56.0K 14.2M 0% /tmp
      tmpfs 512.0K 0 512.0K 0% /dev
      /dev/mtdblock3 1.4M 864.0K 544.0K 61% /overlay
      overlayfs:/overlay 1.4M 864.0K 544.0K 61% /

      Удалить
    4. Этот комментарий был удален автором.

      Удалить
  39. Поставил предыдущую версию из репозитория:
    http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/
    Встало все на ура в соответствие с вашей докой.
    Спасибо!

    ОтветитьУдалить
    Ответы
    1. Мерси за коммент - буду знать на что шиться, если придется перезаливать прошивку.

      Удалить
  40. Всем привет. Наверно я немножко не в тему. Итак заказал я это чудо с Алиэкспрес ждал пару месяцев.Пришёл,распаковал включил зайдя на него мне очень не понравилось что он на китайском ,полез по гуглу нашел почти что надо, прошил его на английский язык ,но там не было вкладки на ещё один диапазон. Я замучился переставлять кабеля туда сюда с одно модема в другой и решил на китайском настроить инет.Полез на модем и поспешил вместо вкладки WAN нажал LAN вбил туда логин пароль который PPPOE и нажал ок ,подождал понял что то не так.С этого момента в настройки модема который WEB интерфейс попасть не могу.На нём на задней панели есть кнопка RESET нажимал её 1000 раз ,держал по 5 мин,выключал модем так держал,держал сразу после включения единственное что я только понял как запустить его Safe режиме.На сетевой ставил разные IP 192.168.1.1 192.168.0.1 и т.д.т.п всё перепробовал не знаю как на нём сбить настройки весь интернет облазил.Может кто чего подскажет? (С компьютерами,сетями,модемами,ролтерами, я не один год опыт есть)
    Кабель приходит в Lan 1 ставил в остальные 3 порта даже в WAN .Вчера пытался сбросить механическим способом.Выключил модем разобрал его провод кинул на ноль и по всем чипам пробегал .Результат нулевой.Кнопка ресет работает так как с её помощью он входит в другой режим.Лампочка в обычном режиме горит постоянно,а если перезапустить ролтер и нажать один раз на ресет она начинает быстро мигать .Роутер TP-Link TL-WDR7500 Прошивка вот эта openwrt-r38298-tl-wdr7500-v2-squashfs-factory Делал с этого сайта http://vol35.ru/viewtopic.php?f=43&t=3478&si…f211ce95700d886c0.
    Модем сам работает так как все лампочки горят как надо.Но в себя не в какую не пускает гад.
    Не знаю что с ним делать :((

    ОтветитьУдалить
    Ответы
    1. Если работает Safe mode, то можно попробовать так: http://blog.tataranovich.com/2013/05/tp-link-tl-wa901nd-debrick.html

      Удалить
    2. Да я так пробовал. Не пускает он в себя не в какую:((

      Удалить
  41. По ошибке в настройках остановил LAN теперь, не зайти в точку ни по wifi ни по lan.Перестала раздавать интернет. Прошу помощи.

    ОтветитьУдалить
  42. Здравствуйте!
    Спасибо за вашу статью, помогла прошить на TL-wa701nd Open-WRT, не знаете как на это точке можно подключиться к PPPOE серверу который у меня в локалке (он раздает инет). Т.е. я хочу эту точку использовать в качестве роутера/NAT для WiFi пользователей. Пробовал создавать новый интерфейс через Web но ни с какими настройками так и не получилось подключиться к PPPOE серверу.

    ОтветитьУдалить
    Ответы
    1. Тут я не смогу помочь. У меня нет под рукой PPPoE сервера для проверки.

      Удалить
  43. Хочу поблагодарить автора за его труды. Как говорят краткость - сестра таланта. Всё получилось с первого раза (хоть и не знаком с линуксом вообще)
    В общем ещё раз спасибо )

    ОтветитьУдалить
  44. Добрый день, легко удалось прошить TL-wa901nd Open-WRT с помощью данной статьи, от DD-WRT отказался ввиду того что отваливается лан порт.
    Подскажите,можете ли вы помочь мне настроить точку ввиду моих запросов. Можно ли сделать так что бы роутеру прописать в wan настройки (кстати где это сделать? Interfaces - LAN?) адрес типа 192.168.1.1 (например), а клиентам подключающимся по wifi роутер выдавал бы адреса другой подсети (например 192.168.2.*)?
    Заранее благодарен за помощь!

    ОтветитьУдалить
    Ответы
    1. Здравствуйте Максим. Рад что мой пост помог вам. К сожалению я не знаю как сделать то, что вы хотите, а разбираться с настройками у меня сейчас нет возможности. Попробуйте задать ваш вопрос на форуме openwrt: https://forum.openwrt.org/

      Удалить
  45. free
    total used free shared buffers
    Mem: 28924 18944 9980 0 1564
    -/+ buffers: 17380 11544
    Swap: 0 0 0


    df -h
    Filesystem Size Used Available Use% Mounted on
    rootfs 832.0K 216.0K 616.0K 26% /
    /dev/root 2.0M 2.0M 0 100% /rom
    tmpfs 14.1M 552.0K 13.6M 4% /tmp
    /dev/mtdblock3 832.0K 216.0K 616.0K 26% /overlay
    overlayfs:/overlay 832.0K 216.0K 616.0K 26% /
    tmpfs 512.0K 0 512.0K 0% /dev


    При установке luci пишет no loft free space, что можно порезать не нужного?

    ОтветитьУдалить
    Ответы
    1. Я недавно обновлял прошивку на точке доступа - все прошло нормально. У OpenWRT бывают моменты, когда текущий билд не помещается в память устройства. У меня в данный момент установлена "BARRIER BREAKER (Bleeding Edge, r40438)".

      # opkg list-installed | grep luci
      luci - svn-r9964-1
      luci-app-firewall - svn-r9964-1
      luci-i18n-english - svn-r9964-1
      luci-lib-core - svn-r9964-1
      luci-lib-ipkg - svn-r9964-1
      luci-lib-nixio - svn-r9964-1
      luci-lib-sys - svn-r9964-1
      luci-lib-web - svn-r9964-1
      luci-mod-admin-core - svn-r9964-1
      luci-mod-admin-full - svn-r9964-1
      luci-proto-core - svn-r9964-1
      luci-proto-ppp - svn-r9964-1
      luci-sgi-cgi - svn-r9964-1
      luci-theme-base - svn-r9964-1
      luci-theme-bootstrap - svn-r9964-1

      Удалить
  46. Добрый день. Хочу сделать с точки wa901 сделать роутер openwrt. Чтоб LAN был WAN, а раздача была по вайфай. Скажите можно ли так? Если есть у кого выложите пожалуста прошивку уже с Luci. А то интернет только на ноуте через VPN, другого роутера нет (Dir300 сгорел). Спасибо!

    ОтветитьУдалить
    Ответы
    1. Здравствуйте, Александр. Сделать из WA901 роутер скорее всего можно (возможно не потребуется копаться в конфигах и все делается из Luci), но я не пробовал так делать и не могу дать конкретных рекомендаций. Да и свободной железки чтобы попробовать это сделать у меня сейчас нет. Попробуйте задать ваш вопрос на форуме OpenWRT: https://forum.openwrt.org/

      Удалить
  47. Здравствуйте.
    Сделал как вы написали, но на web консоль не заходит, вылетает мимолетно черный экран, а потом белый, ошибка gateway, как быть?

    ОтветитьУдалить
    Ответы
    1. По SSH/Telnet зайти можете? Если да, то смотрите запущен ли веб-сервер

      netstat -tn | grep :80

      Удалить
    2. Захожу, прекрасно взаимодействую с роутером. У меня tl-wa901nd, единственная сложность, что uhttpd в автозагрузку не встает, т.к. места на девайсе маловато остается после установки luci.
      Сделал эту команду "netstat -tn | grep :80", ничего не произошло, делал через SSH. Эффекта нет, что делать?

      Удалить
    3. Поправка, вылетело
      "tcp 0 0 192.168.1.1:80 192.168.1.11:3631 TIME_WAIT"

      Удалить
    4. Вот картинка того, что вылетает при попытки подключиться через браузер
      http://cs624522.vk.me/v624522460/9adb/i1HAtqxTK-8.jpg

      Удалить
    5. не могу все уместить в одно сообщение))
      Вот это было при установке luci, мне кажется, что тут чего-то не хватает?
      Configuring liblua.
      Configuring libuci-lua.
      Configuring libubus-lua.
      Configuring libiwinfo-lua.
      Configuring luci-theme-bootstrap.
      Configuring luci-app-firewall.
      Configuring lua.
      Configuring luci-proto-ppp.
      Configuring luci-base.
      Configuring luci-mod-admin-full.
      Configuring uhttpd.

      Удалить
    6. я кажется понял причину... у меня не хватает места под установку всех пакетов... Как вы делали установку, ведь аппараты одинаковые?
      Configuring liblua.
      Configuring libuci-lua.
      Configuring libubus-lua.
      Configuring libiwinfo-lua.
      Configuring luci-theme-bootstrap.
      Configuring luci-app-firewall.
      Configuring lua.
      Configuring luci-proto-ppp.
      Configuring luci-base.
      Configuring luci-mod-admin-full.
      Configuring uhttpd.
      ln: /etc/rc.d/S50uhttpd: No space left on device
      Configuring uhttpd-mod-ubus.
      Collected errors:
      * wfopen: /lib/upgrade/luci-add-conffiles.sh: No space left on device.
      * pkg_write_filelist: Failed to open //usr/lib/opkg/info/luci-lib-nixio.list: No space left on device.
      * opkg_install_pkg: Failed to extract data files for luci-lib-nixio. Package debris may remain!
      * opkg_install_cmd: Cannot install package luci.
      * opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: No space left on device.

      Удалить
    7. Я делал это больше 2 лет назад - тогда все установилось без проблем. Стоит подождать пару дней и попробовать снова. Перечитайте комментарии - есть несколько жалоб, что сначала не хватало места, но через пару дней все устанавливается.

      Удалить
    8. чудеса какие-то)) ну хорошо, я просмотрю комментарии, а сейчас пытаюсь сделать необходимые настройки через консоль, мне надо подключиться к wi-fi и чтоб комп, подключенный через lan тоже получил интернет, избегая всякий сервисов типа nat и др., более "прозрачным" способом так сказать)

      Удалить
    9. Здравствуйте!
      В общем, все получилось, достаточно было использовать версию сборки чуть позднюю, а не последнюю. Так же сразу был и luci. Спасибо вам за статью!

      Удалить
  48. Добрый день. Поставил на роутер прошивку OpenWRT, в данный момент роутер подключен в режиме коммутатора, сеть работает, но на самом роутере интернета нет. В чем может быть моя ошибка?

    ОтветитьУдалить
  49. Здраствуйте, нужна ваша помощ. Сделал вот так. В итоге не заходит в бразере Bad Gateway. Пожалуста помогите.


    root@(none):/# cd /tmp
    root@(none):/tmp# wget http://downloads.openwrt.org/snapshots/trunk/ar71xx/openw
    rt-ar71xx-generic-tl-wa901nd-v1-squashfs-sysupgrade.bin
    Connecting to downloads.openwrt.org (78.24.191.177:80)
    openwrt-ar71xx-gener 100% |*******************************| 3072k 0:00:00 ETA
    root@(none):/tmp# wget http://downloads.openwrt.org/snapshots/trunk/ar71xx/md5su
    ms
    Connecting to downloads.openwrt.org (78.24.191.177:80)
    md5sums 100% |*******************************| 38179 0:00:00 ETA
    root@(none):/tmp# md5sum -c md5sums 2>/dev/null | grep -v FAILED$
    openwrt-ar71xx-generic-tl-wa901nd-v1-squashfs-sysupgrade.bin: OK
    root@(none):/tmp# openwrt-ar71xx-generic-tl-wa901nd-v1-squashfs-sysupgrade.bin:
    OK
    /bin/ash: openwrt-ar71xx-generic-tl-wa901nd-v1-squashfs-sysupgrade.bin:: not fou nd
    root@(none):/tmp# mtd -r write openwrt-ar71xx-generic-tl-wa901nd-v1-squashfs-sys
    upgrade.bin firmware
    Unlocking firmware ...

    Writing from openwrt-ar71xx-generic-tl-wa901nd-v1-squashfs-sysupgrade.bin to fir mware ...
    Rebooting ...




    root@(none):/# passwd root
    Changing password for root
    New password:
    Bad password: too short
    Retype password:
    passwd: /etc/passwd: Read-only file system
    passwd: can't update password file /etc/passwd
    root@(none):/# echo 'nameserver 8.8.8.8' > /etc/resolv.conf
    root@(none):/# route add default gw 192.168.1.2
    route: SIOCADDRT: File exists
    root@(none):/# opkg update
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/base/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_base.
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/luci/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_luci.
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/management/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_management.
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/packages/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/routing/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_routing.
    Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/telephony/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_telephony.
    root@(none):/# opkg install luci
    Installing luci (git-14.359.33351-5e6c33e-1) to root...
    Collected errors:
    * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
    * opkg_install_cmd: Cannot install package luci.
    root@(none):/# /etc/init.d/uhttpd enable
    /bin/ash: /etc/init.d/uhttpd: not found
    root@(none):/# /etc/init.d/uhttpd start
    /bin/ash: /etc/init.d/uhttpd: not found
    root@(none):/#

    ОтветитьУдалить
    Ответы
    1. У вас не установился luci из-за нехватки свободного места:

      Collected errors:
      * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
      * opkg_install_cmd: Cannot install package luci.

      можно попробовать другую прошивку (не trunk)

      Удалить
  50. Пожалуйста сделайте фул флеш для WA901ND v1.0. Так как уже не попасть в fail safe mode.

    ОтветитьУдалить
  51. может кому пригодится

    у меня TP-Link TL-WA901ND v2
    роботает по pppoe с провайдером

    обновил прошивку до Chaos Calmer 15.05.1
    но потом заметил что сайт рамблер открывается через секунд 10 (после нескольих часов использования роутера)

    поставил прошивку Barrier Breaker 14.07
    2 дня полет нормальный, все открывается моментально

    не знаю в чем проблемма единственная разница кажется то что в 15 прошивке канал был 12 у вайфай? а в 14 нельзя поставить 12 поэтому ставлю 3 канал
    в остальном конфиги идентичны

    приведу свои конфиги, интернет раздается по wifi с провайдером соеденяется по pppoe

    wireless

    config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ath9k'
    option htmode 'HT20'
    option txpower '20'
    option country 'RU'
    option channel '3'

    config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'XXXX'
    option encryption 'psk2'
    option key 'XXXXXX'
    option network 'lan'


    network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fda4:56ee:9a98::/48'

    config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.254'
    option netmask '255.255.255.0'
    option _orig_ifname 'eth0 wlan0'
    option _orig_bridge 'true'
    option delegate '0'

    config interface 'wan'
    option proto 'pppoe'
    option ifname 'eth0'
    option username 'XXXXXXX'
    option password 'XXXXXXX'
    option delegate '0'

    ОтветитьУдалить
    Ответы
    1. не знаю в чем проблемма единственная разница кажется то что в 15 прошивке канал был 12 у вайфай? а в 14 нельзя поставить 12 поэтому ставлю 3 канал

      Wifi лучше настраивать по схеме трех каналов: 1, 6 и 11. Эти три канала не пересекаются между собой по частоте.

      Удалить
  52. Этот комментарий был удален администратором блога.

    ОтветитьУдалить
  53. А что что означает instance?
    https://preply.com/question/chto-oznachaet-instance

    ОтветитьУдалить